FreeNAS und LSI SAS 9211-8i

By | 17. Januar 2015

Hallo,

nach der Installation von FreeNAS 9.3 mit der anschließenden Konfiguration, hatte ich schon ein „Alert“ der Stufe Gelb im Webinterface.

System Warning: WARNING: Firmware version 20 does not match driver version 16 for /dev/mps0

Es gibt zwei Lösungen:

  1. Die Karte auf die Firmware Version 16 flashen
  2. Neue Treiber verwenden

Die 1. Lösung habe ich schon gezeigt und die 2. Lösung, die ich verwende, zeig ich jetzt.

Folgende Schritte sind dazu nötig:

  1. FreeBSD Treiber herunterladen vom Hersteller LSI
  2. Die Datei entpacken und das darin enthaltene Archiv (.tar) entpacken
  3. Für 64bit: Die Datei im Verzeichnis pkg\stage\9.3.0\amd64\boot\kernel\mpslsi.ko muss nach /boot/modules auf dem FreeNAS System
  4. Für 32bit: Die Datei im Verzeichnis pkg\stage\9.3.0\i386\boot\kernel\mpslsi.ko muss nach /boot/modules auf dem FreeNAS System
  5. Wie in der FreeNAS Doku beschrieben einen neuen Eintrag Tunables oder anpassbare Parameter anlegen und folgende Werte eintragen:
    • Veränderbar: mpslsi_load
    • Wert: YES
    • Type: Loader
    • Kommentar: LSI P20 Driver
    • Aktiviert angekreuzt
  6. FreeNAS neustarten

Tunables LSI P20

Überprüfen kann man das indem das Alert nicht mehr erscheint oder mit folgendem Befehl (im Webinterface die Konsole öffnen):

# sysctl -a |grep mpslsi
[...]
dev.mpslsi.0.firmware_version: 20.00.00.00
dev.mpslsi.0.driver_version: 20.00.00.00

Beide Zahlenwert sollten nun übereinstimmen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.